Installation cAlgo/CTrader on Windows Server 2016

cicondo since: 18 Dec 2012;

  15 Dec 2017, 10:27
Installation cAlgo/CTrader on Windows Server 2016

Good Day,

I'm trying to install the clickonce Installation in a W-Server 2016, which is a deidcated server, I rent

But I get this type of error:


> An error occurred trying to download
> 'http://fxpro.ctrader.com/xTrader-FxPro.application'.

> See the setup log file located at
> 'C:\Users\ADMINI~1\AppData\Local\Temp\2\VSD60DB.tmp\install.log' for more
> information.

> the content of the given file is below:

> esult of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi'
> and value '4.5': true
> Result of checks for command 'WindowsInstaller4_5\WindowsXP-KB942288-v3-x86.exe'
> is 'Bypass'
> Running checks for command 'WindowsInstaller4_5\WindowsXP-KB958655-v2-x86-ENU.exe'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'VersionMsiDll' and value '4.5.6001.22299': true
> Result of checks for command
> 'WindowsInstaller4_5\WindowsXP-KB958655-v2-x86-ENU.exe' is 'Bypass'
> Running checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x86.exe'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi'
> and value '4.5': true
> Result of checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x86.exe' is 'Bypass'
> Running checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB958655-v2-x86-ENU.exe'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'VersionMsiDll' and value '4.5.6001.22299': true
> Result of checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB958655-v2-x86-ENU.exe' is 'Bypass'
> Running checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x64.exe'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi'
> and value '4.5': true
> Result of checks for command
> 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x64.exe' is 'Bypass'
> Running checks for command
> 'WindowsInstaller4_5\WindowsServer2003.WindowsXP-KB958655-v2-x64-ENU.exe'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'VersionMsiDll' and value '4.5.6001.22299': true
> Result of checks for command
> 'WindowsInstaller4_5\WindowsServer2003.WindowsXP-KB958655-v2-x64-ENU.exe' is
> 'Bypass'
> Running checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x86.MSU'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'VersionMsiDll' and value '4.5.6001.22308': true
> Result of checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x86.MSU'
> is 'Bypass'
> Running checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x64.MSU'
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'VersionMsiDll' and value '4.5.6001.22308': true
> Result of checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x64.MSU'
> is 'Bypass'
> 'Windows Installer 4.5' RunCheck result: No Install Needed
> Running checks for package 'Microsoft .NET Framework 4 Client Profile (x86 and
> x64)', phase BuildList
> Reading value 'Version' of registry key 'HKLM\Software\Microsoft\NET Framework
> Setup\NDP\v4\Client'
> Read string value '4.6.01586'
> Setting value '4.6.01586 {string}' for property 'DotNet40Client_TargetVersion'
> The following properties have been set for package 'Microsoft .NET Framework 4
> Client Profile (x86 and x64)':
> Property: [DotNet40Client_TargetVersion] = 4.6.01586 {string}
> Running checks for command 'DotNetFX40Client\dotNetFx40_Client_x86_x64.exe'
> Result of running operator 'ValueEqualTo' on property 'InstallMode' and value
> 'HomeSite': true
> Result of checks for command 'DotNetFX40Client\dotNetFx40_Client_x86_x64.exe' is
> 'Bypass'
> Running checks for command 'DotNetFX40Client\dotNetFx40_Client_setup.exe'
> Result of running operator 'ValueNotEqualTo' on property 'InstallMode' and value
> 'HomeSite': false
> Result of running operator 'VersionGreaterThanOrEqualTo' on property
> 'DotNet40Client_TargetVersion' and value '4.0.30129': true
> Result of checks for command 'DotNetFX40Client\dotNetFx40_Client_setup.exe' is
> 'Bypass'
> 'Microsoft .NET Framework 4 Client Profile (x86 and x64)' RunCheck result: No
> Install Needed
> Launching Application.
> URLDownloadToCacheFile failed with HRESULT '-2146697208'
> Error: An error occurred trying to download
> 'http://fxpro.ctrader.com/xTrader-FxPro.application'.

Has anybody some ideas, whats going on? And how to fix it? 
My local installation works fine.

Thx @all

ap11's avatar

ap11 since: 28 Jun 2017;

  15 Dec 2017, 11:45

Hi cicondo,

There is a problem with installation when some Internet Explorer security settings enabled.

Go to Server Manager -> Local Server -> Set IE Enhanced Security Configuration = Off

Kind Regards,
Andrey

Product Manager of cTrader Desktop at Spotware