Ichimoku Indicator Error

12 Jun 2018, 17:31Ichimoku Indicator Error#1
solomonawulonuposts: 2since: 10 Jun 2018

Dear Support, While using Ichimoku Indicator I observed that the value for Span A and Span B are mixed.

Ichimoku Indicator while attached to the chart is ok. But when referenced in cBot the value of Span A is actually Span B. while the value of Span B is actually Span A.

Please do fix this error.


http://fxseed.com
13 Jun 2018, 09:21#2
Panagiotis Charalampousposts: 1200since: 13 Jan 2017

Hi solomonawulonu,

Thanks for posting in our forum and for reporting this issue. We will investigate and fix if there is a problem.

Best Regards,

Panagiotis


Head of Community Management at cTrader
13 Jun 2018, 10:48#3
Panagiotis Charalampousposts: 1200since: 13 Jan 2017

Hi Solomon,

We had a look at this but we don't see any issue. Could you please send us more information e.g. a screenshot and/or a cBot?

Best Regards,

Panagiotis


Head of Community Management at cTrader
13 Jun 2018, 11:25#4
solomonawulonuposts: 2since: 10 Jun 2018

Dear Support,

The following lines are part of the code in the cBot.

IchimokuKinkoHyo Ichimoku  = Indicators.IchimokuKinkoHyo(9, 26, 52);

double ichimoku_main = Ichimoku.KijunSen.Last(0);
double ichimoku_span_a = Ichimoku.SenkouSpanA.Last(0);
double ichimoku_span_b = Ichimoku.SenkouSpanB.Last(0);

 

The value of ichimoku_span_a is wrong. Attach the indicator to chart and read the value manually.

The value of ichimoku_span_b is wrong. Attach the indicator to chart and read the value manually.

 

I observed that the values are swapped. ichimoku_span_a is actually ichimoku_span_b and vice versa.

 

Best Regards

Awulonu, Solomon Chidozie


http://fxseed.com
13 Jun 2018, 11:40#5
Panagiotis Charalampousposts: 1200since: 13 Jan 2017

Hi Solomon,

This is what I do but seems correct. See below

Can you send a similar screenshot?

Best Regards,

Panagiotis


Head of Community Management at cTrader