Set curly brackets - not possible with CTRL ALT 7/0

kebbo since: 28 Sep 2020;

  29 May 2021, 19:02
Set curly brackets - not possible with CTRL ALT 7/0

Hello dear cTrader Community,

a slightly "different" problem:

I have since a few days the problem that I can not set curly brackets anymore, when programming cAlgo code this is very very annoying.
I'm afraid I can't solve the problem without your help.

-STRG ALT + 7 or 0 does not work. ALT GR does not work either. The square brackets as well as the @ does not work either.
However, the problem occurs only in the cTrader software, and only on my own computer system (cTrader in Remote Desktop works, with the same keyboard) .
Copy and paste works, but is very annoying and not the point.

What could be the problem, can someone help me? I have already reinstalled the cTrader software, that also brought no success. What else could I do?

Best regards
kebbo

sandrete66 since: 10 Jun 2021;

  10 Jun 2021, 18:31

Hey!

I've got the same issue, I can't type anything requiring CTRL+ALT or ALTGR key, which means I can't type square or curly brackets, which turns scripting a real pain. 

Does anyone really know how to fix this issue? I would really appreciate it.

Thanks!

PS: as you can see, anywhere else I can type those symbols { } [ ], it only happens in the cAutomate editor

PanagiotisCharalampous's avatar

PanagiotisCharalampous since: 13 Jan 2017;

  11 Jun 2021, 08:55

Hi to both,

Not sure what systems or keyboards do you use but curly brackets on a Windows machine with a US keyboard are typed using Shift + [. 

Best Regards,

Panagiotis 

Join us on Telegram and Facebook

Head of Community Management at cTrader

kebbo since: 28 Sep 2020;

  11 Jun 2021, 19:07
RE:

PanagiotisCharalampous said:

Hi to both,

Not sure what systems or keyboards do you use but curly brackets on a Windows machine with a US keyboard are typed using Shift + [. 

Best Regards,

Panagiotis 

Join us on Telegram and Facebook

Hi you two!

Thanks first of all for the answers and participation! Unfortunately the problem still exists, Spotware directly could not help me and referred me again to this forum.
I hope we can still solve the problem together.

It is definitely not the keyboard, because the PC setup and the hardware worked fine before. Furthermore the CTRL ALT functions do not work only in the code editor! If I enter the curly bracket in the "cBot search field", it works! It works everywhere but not in the code editor of the cTrader software on this single PC.... Reinstallation didn't help unfortunately....very strange...it happened while programming, maybe I pressed a key combination by mistake, and triggered this bug...still I haven't solved it yet....


Thank you guys and have a nice weekend!

kebbo