Ver 4.4.15 Notifications.SendEmail Faild, please help

Capt.Z-Fort.Builder's avatar

Capt.Z-Fort.Builder since: 03 Jun 2020;

  29 Oct 2022, 00:43
Ver 4.4.15 Notifications.SendEmail Faild, please help

Hello,

I have the below code, which works fine for a long time, until this Monday 24 Oct. 2022

using System;
using System.Linq;
using System.Globalization;
using cAlgo.API;
using cAlgo.API.Indicators;
using cAlgo.API.Internals;
using cAlgo.Indicators;

namespace cAlgo.Robots
{
    [Robot(TimeZone = TimeZones.UTC, AccessRights = AccessRights.None)]
    public class TestBot : Robot

    {
    
        protected override void OnStart()
        {

            //Test Email Function
            string sSubject =  "Symbol.Name + X"; 
            string sMessage = Bars.LastBar.Close + " ↘↘↘ " + Server.Time.AddHours(0).ToString("HH:mm:ss"); 
            Notifications.SendEmail("xxx@icloud.com", "xxx@hotmail.com", sSubject, sMessage);

        }

    }

}

The error code is below screenshot, which happens in version 4.4.15.9791, and was downloaded from Spotware directly. I'm sure the email setting has no problem. Please advise. Thanks.

Spotware's avatar

Spotware since: 23 Sep 2013;

  21 Nov 2022, 10:34

Dear trader,

Please follow the instructions specified in this discussion and let us know if they help.

Best regards,

cTrader Team

TRADERS FIRST™ Vote for your favorite features: https://ctrader.com/forum/suggestions
Capt.Z-Fort.Builder's avatar

Capt.Z-Fort.Builder since: 03 Jun 2020;

  21 Nov 2022, 11:45
RE:

Hello Team,

I've followed the process and installed the tls_fix_v2.reg as below, but the problem is still there.

Spotware said:

Dear trader,

Please follow the instructions specified in this discussion and let us know if they help.

Best regards,

cTrader Team