Empty respose on ProtoOAApplicationAuthReq()

silvio.jurk since: 17 May 2023;

  26 May 2023, 02:46
Empty respose on ProtoOAApplicationAuthReq()


I workes since 2 years with my application on OpenAPI and all workes fine but since 2 days (25.05.23) it just don't work and is not able to connect with ProtoOAApplicationAuthReq(). I just get the following payloads: 2101 and 51. The response is always "{}". Is something happend on the protocol. The version of the api is ctrader-open-api==0.9.1. I used also the simplest sample code from tutorial but this also not worked. 

My Endpoinds are: 

class EndPoints:
    AUTH_URI = "https://openapi.ctrader.com/apps/auth"
    TOKEN_URI = "https://openapi.ctrader.com/apps/token"
    PROTOBUF_DEMO_HOST = "demo1.p.ctrader.com"
    PROTOBUF_LIVE_HOST = "live1.p.ctrader.com"
    PROTOBUF_PORT = 5035
PanagiotisChar's avatar

PanagiotisChar since: 15 Sep 2022;

  26 May 2023, 08:07

Hi there,

Do you still experience this problem? I tried it with the sample application and have no issues at the moment.

Aieden Technologies

Need help? Join us on Telegram

Need premium support? Trade with us

Cofounder and Chief Technologist at Aieden Technologies

silvio.jurk since: 17 May 2023;

  26 May 2023, 12:36

Ok I solved it. I'm just stupid... :)