Not possible to enter "," or "." for decimals in lot size input field on iPhone app

erik.lindblad since: 05 Mar 2019;

  15 Apr 2020, 14:53
Not possible to enter "," or "." for decimals in lot size input field on iPhone app

Hi!

This issue has been here for at least a year since when I started to use cTrader on iPhone. You cannot enter a comma or a point in the lot size input field. Only way to get a point (dot) in there is to select a predefined lot size in the drop down. However, when trying to alter it, removing the digit right after the point (dot) removes the point (dot). So there is no way around it. I have actually lost money on this one not being able to manage my risk while away from my computer. My trader friends using iPhone has confirmed the issue.

Please fix this as soon as possible, I guess it is a pretty simple fix.

Thanks!

PanagiotisCharalampous's avatar

PanagiotisCharalampous since: 13 Jan 2017;

  15 Apr 2020, 15:12

Hi erik.lindblad,

This has been fixed in a recent update. Can you please tell us which version and broker do you use and which iPhone do you have?

Best Regards,

Panagiotis 

Join us on Telegram

Head of Community Management at cTrader

erik.lindblad since: 05 Mar 2019;

  15 Apr 2020, 15:59
RE:

PanagiotisCharalampous said:

Hi erik.lindblad,

This has been fixed in a recent update. Can you please tell us which version and broker do you use and which iPhone do you have?

Best Regards,

Panagiotis 

Join us on Telegram

Thanks for your reply!

I am using IC Markets and cTrader version 3.11.54240

/Erik

PanagiotisCharalampous's avatar

PanagiotisCharalampous since: 13 Jan 2017;

  15 Apr 2020, 16:49

Hi erik.lindblad,

We could not reproduce such a behavior. Can you please provide us the following as well?

1. iOS version

2. Device information

3. The symbol you are trying to trade

4. A screenshot of the application at the time you are putting the relevant value

Best Regards,

Panagiotis 

Join us on Telegram

Head of Community Management at cTrader

erik.lindblad since: 05 Mar 2019;

  15 Apr 2020, 21:57
RE:

PanagiotisCharalampous said:

Hi erik.lindblad,

We could not reproduce such a behavior. Can you please provide us the following as well?

1. iOS version

2. Device information

3. The symbol you are trying to trade

4. A screenshot of the application at the time you are putting the relevant value

Best Regards,

Panagiotis 

Join us on Telegram

That is strange. I have an iPhone X

iOS version 13.3.1

It happens on all pairs when trying to edit a PENDING LIMIT order, I don't know about other order types, I only use limit orders.

When I try to modify the lot size using comma (there is no dot on the digital keyboard that appears) it clears the entire input field and gives an error message.


 

erik.lindblad since: 05 Mar 2019;

  04 May 2020, 00:23
RE:

PanagiotisCharalampous said:

Hi erik.lindblad,

We could not reproduce such a behavior. Can you please provide us the following as well?

1. iOS version

2. Device information

3. The symbol you are trying to trade

4. A screenshot of the application at the time you are putting the relevant value

Best Regards,

Panagiotis 

Join us on Telegram

Any news regarding this? Moreover, you cannot enter a take profit or stop loss price on an order in the iPhone app. You have to specify the take profit and stop loss in pips and you cannot edit the price level. I am sorry but this does not make sense to me.

Best Regards

Erik

PanagiotisCharalampous's avatar

PanagiotisCharalampous since: 13 Jan 2017;

  04 May 2020, 10:48

Hi erik.lindblad,

We have reproduced the issue and it will be fixed in an upcoming update. In the meanwhile a workaround is to change your region to one that considers "." as a separator through Settings -> General -> Region.

Best Regards,

Panagiotis 

Join us on Telegram

Head of Community Management at cTrader

erik.lindblad since: 05 Mar 2019;

  04 May 2020, 11:37
RE:

PanagiotisCharalampous said:

Hi erik.lindblad,

We have reproduced the issue and it will be fixed in an upcoming update. In the meanwhile a workaround is to change your region to one that considers "." as a separator through Settings -> General -> Region.

Best Regards,

Panagiotis 

Join us on Telegram

Sounds good. And thanks for the workaround!

/Erik