CPU consumption on Ctrader Desktop

12 Feb 2019, 07:00CPU consumption on Ctrader Desktop#1
tasr1r1posts: 28since: 25 Dec 2012

Anybody experiencing high CPU utilisation after the latest update?

im running cTrader on three machine.. laptop office (intel i5-4310U CPU 4GB RAM) at home (Ryzen 5 2600 16GB RAM) and remote VPS.

I notice high CPU utilisation and fluctuation recently.. its really bothering as its slow down everything from opening new window, changing view and running backtesting. almost every single click will make the application to freeze for loading.

Its really frustrating as i spent most of the time testing and writing ea codes.

12 Feb 2019, 09:35#2
Panagiotis Charalampousposts: 2168since: 13 Jan 2017

Hi tasr1r1,

Can you provide us with more information? Do you run any custom indicators/cBots when this happens? How many charts do you have open? Any objects on the charts? The more information you can provide about the setup, the easier will be for us to reproduce and investigate.

Best Regards,

Panagiotis


Head of Community Management at cTrader
12 Feb 2019, 18:01#3
tasr1r1posts: 28since: 25 Dec 2012

my home pc currently opening 3 charts with 2 different pairs (different TF). I started to experience sluggishness again when changing view from Automate to Trade tab when running backtesting on 1 pair. I am sure this is not a problem before but now the mouse cursor will always change to loading mode when clicking between the tab.  automation only run by another vps. current open trade is 10.. i used to have over 1k open trade via vps and able to do backtesting and switching view in a snap previously

12 Feb 2019, 19:00#4
tasr1r1posts: 28since: 25 Dec 2012

it seems like the ctrader is holding the resources even after backtesting was completed until the app become sluggish.. i tried to get back to my codes by scrolling it but it was badly lag until i cant find the line that i was looking for. restarting ctrader helps and i can scroll the code like before

13 Feb 2019, 09:58#5
Panagiotis Charalampousposts: 2168since: 13 Jan 2017

Hi tasr1r1,

Can you send us some troubleshooting information when this happens again? To do so, press Ctrl+Alt+Shit+T, paste in the textbox the link to this discussion and press Submit.

Best Regards,

Panagiotis


Head of Community Management at cTrader