cTrader 4.2/4.3 compiling problem "CT0002: Assembly must contain algo type."

wolters since: 25 Mar 2022;

  21 Jul 2022, 19:12
cTrader 4.2/4.3 compiling problem "CT0002: Assembly must contain algo type."

Hi.

I have an indicator using a lot of different packages and dependent projects. I can compile with the .net target 4.x against the 4.3 cTrader API with VS2019.
The created algo file does not get loaded by cTrader. If I try to compile the same project by cTrader, it produces the error:


"CT0002: Assembly must contain algo type.".

Everything works as expected if compiled with 4.1.
Any idea what may cause the problem?


I read about the same error message with a similar scenario (https://ctrader.com/forum/calgo-support/37861) - but I could not get it to work by just marking the dependent libraries with a PropertyGroup as described.


What do I need to do to explicitly set the missing algo type?

Best
Carsten

PanagiotisCharalampous's avatar

PanagiotisCharalampous since: 13 Jan 2017;

  25 Jul 2022, 12:16

Hi wolters,

Please send us the indicator's source code at community@spotware.com and we wll have a look.

Best Regards,

Panagiotis 

Join us on Telegram and Facebook

Head of Community Management at cTrader

wolters since: 25 Mar 2022;

  25 Jul 2022, 12:21

The problem is solved.

In this case, it was a class defined as "internal" instead of "public" that seems to hide the information in the assembly.

Best,
Carsten