Paolo B
Paolo B's avatar

Info

Username:paolobrionesph@gmail.com
Name:Paolo B
Member since: 14 Mar 2018

About

None

Signature

None

Last Forum Posts

@ProtoOAAccountAuthReq hangs when called:  24 Sep 2022, 03:01


I eventually figured it out, when the cTrader.OpenAPI.NET library initializes the OpenClient class, the host parameter is typically retrieved via the ApiInfo.GetHost() method, which returns "demo.ctraderapi.com" or "live.ctraderapi.com".

However, when I was reading the documentation I found the article about Proxies/Endpoints (https://help.ctrader.com/open-api/proxies-endpoints/) and it outlines several regional proxy servers to use, such as "demo-sg.ctraderapi.com" etc, so I tried this out and just hardcoded the host parameter to the OpenClient ctor and it worked!

I was able to connect and issue ProtoOA* requests to the OpenAPI server without any problems.

paolobrionesph@gmail.com said:

Hello,

This issue started happening this morning (Manila, PH time).

The initial call to ProtoOAApplicationAuthReq/ProtoOAApplicationAuthRes was completed successfully and my application was able to authenticate with my Client ID/Secret.

The secondary call to ProtoOAAccountAuthReq/ProtoOAAccountAuthRes hangs and never returns any value via the Subscribe() response handler, no errors were also reported. it just hangs indefinitely.

This issue also happens to both Demo Spotware accounts, and Live ICM/Pepperstone accounts.

I remember this happening in the past, but after a few hours everything worked again properly.

I am currently running the code in C#, VS2022 (fully patched), ASPNETCORE 6, Dotnet6, Windows 11 (fully patched), no changes to the existing code and the same code worked yesterday without any issues. Using the latest version of cTrader.OpenAPI.NET v1.4.4 from nuget

Looking forward to a resolution to the problem :(

Sincerely,

Paolo

@ProtoOAAccountAuthReq hangs when called:  23 Sep 2022, 07:25


Hello,

This issue started happening this morning (Manila, PH time).

The initial call to ProtoOAApplicationAuthReq/ProtoOAApplicationAuthRes was completed successfully and my application was able to authenticate with my Client ID/Secret.

The secondary call to ProtoOAAccountAuthReq/ProtoOAAccountAuthRes hangs and never returns any value via the Subscribe() response handler, no errors were also reported. it just hangs indefinitely.

This issue also happens to both Demo Spotware accounts, and Live ICM/Pepperstone accounts.

I remember this happening in the past, but after a few hours everything worked again properly.

I am currently running the code in C#, VS2022 (fully patched), ASPNETCORE 6, Dotnet6, Windows 11 (fully patched), no changes to the existing code and the same code worked yesterday without any issues. Using the latest version of cTrader.OpenAPI.NET v1.4.4 from nuget

Looking forward to a resolution to the problem :(

Sincerely,

Paolo

Notification Publishing copyrighted material is strictly prohibited. If you believe there is copyrighted material in this section you may use the Copyright Infringement Notification form to submit a claim.

No uploaded.

Warning! Executing cBots downloaded from this section may result in loss of funds. Use them at your own risk.

No uploaded.